It’s Only Logical To Update To Vulkan On Your Raspberry Pi 4 1

It’s Only Logical To Update To Vulkan On Your Raspberry Pi 4

General Tech
Spread the love
It’s Only Logical To Update To Vulkan On Your Raspberry Pi 4 2

You Won’t Be Playing Crysis But You Could Play Quake

The Raspberry Pi 4 depends on OpenGL to render it’s graphics, which is not optimal as the industry is trying to move away from the dated API to the more modern Vulkan interface.  Today support for Vulkan 1.2 on the Raspberry Pi 4 was announced, after a lengthy certification process.  You can’t grab it as an update quite yet, but a new OS version should arrive soon so that you can try it out.

As Ars Technica points out, those using a RasPi as a min-server are not going to notice much difference as they don’t really make use of a GUI or other features which require graphical interfaces. However for those that do use the Broadcom VideoCore VI GPU, the upgrade should be noticeable because of Vulkan’s reduced overhead compared to OpenGL.

If you build or make use of Android apps on your Raspberry Pi 4 then you should definitely keep an eye out for the update, as it will have an effect on your system.  It should also make development more effective since you will be able to use the new features available in Vulkan, as well as being able to port existing apps much easier.

Get more details here.